summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/patches/coreutils-racy-tail-test.patch13
3 files changed, 17 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 40a5841717..d3a9527939 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -415,6 +415,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/clang-libc-search-path.patch		\
   gnu/packages/patches/clucene-pkgconfig.patch			\
   gnu/packages/patches/cmake-fix-tests.patch			\
+  gnu/packages/patches/coreutils-racy-tail-test.patch		\
   gnu/packages/patches/cpio-CVE-2014-9112-pt1.patch		\
   gnu/packages/patches/cpio-CVE-2014-9112-pt2.patch		\
   gnu/packages/patches/cpio-CVE-2014-9112-pt3.patch		\
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e2d4727c9c..f60a6cfeef 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -248,7 +248,9 @@ used to apply commands with arbitrarily long arguments.")
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))))
+              "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
+            (patches
+             (list (search-patch "coreutils-racy-tail-test.patch")))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)                        ;bignums in 'expr', yay!
diff --git a/gnu/packages/patches/coreutils-racy-tail-test.patch b/gnu/packages/patches/coreutils-racy-tail-test.patch
new file mode 100644
index 0000000000..91640513e4
--- /dev/null
+++ b/gnu/packages/patches/coreutils-racy-tail-test.patch
@@ -0,0 +1,13 @@
+Skip this test, which uncovers a race condition in how 'tail' handles
+file deletion.  See <http://bugs.gnu.org/21460>.
+
+--- a/tests/tail-2/assert.sh
++++ b/tests/tail-2/assert.sh
+@@ -16,6 +16,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program.  If not, see <http://www.gnu.org/licenses/>.
+ 
++exit 77				# see <http://bugs.gnu.org/21460>
+ 
+ # This test fails with tail from textutils-2.0.
+ # It would get something like this: