summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--guix/import/gem.scm3
-rw-r--r--tests/gem.scm82
3 files changed, 86 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 711181b7cf..9a810e4ebd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -231,7 +231,8 @@ MODULES +=					\
 
 SCM_TESTS += 					\
   tests/pypi.scm				\
-  tests/cpan.scm
+  tests/cpan.scm				\
+  tests/gem.scm
 
 endif
 
diff --git a/guix/import/gem.scm b/guix/import/gem.scm
index 3c28d1d9fd..c64c4e9374 100644
--- a/guix/import/gem.scm
+++ b/guix/import/gem.scm
@@ -105,8 +105,9 @@ VERSION, HASH, HOME-PAGE, DESCRIPTION, DEPENDENCIES, and LICENSES."
      (description ,description)
      (home-page ,home-page)
      (license ,(match licenses
+                 (() #f)
                  ((license) (license->symbol license))
-                 (_ (map license->symbol licenses))))))
+                 (_ `(list ,@(map license->symbol licenses)))))))
 
 (define* (gem->guix-package package-name #:optional version)
   "Fetch the metadata for PACKAGE-NAME from rubygems.org, and return the
diff --git a/tests/gem.scm b/tests/gem.scm
new file mode 100644
index 0000000000..9efbda31fe
--- /dev/null
+++ b/tests/gem.scm
@@ -0,0 +1,82 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-gem)
+  #:use-module (guix import gem)
+  #:use-module (guix base32)
+  #:use-module (guix hash)
+  #:use-module (guix tests)
+  #:use-module ((guix build utils) #:select (delete-file-recursively))
+  #:use-module (srfi srfi-64)
+  #:use-module (ice-9 match))
+
+(define test-json
+  "{
+  \"name\": \"foo\",
+  \"version\": \"1.0.0\",
+  \"sha\": \"f3676eafca9987cb5fe263df1edf2538bf6dafc712b30e17be3543a9680547a8\",
+  \"info\": \"A cool gem\",
+  \"homepage_uri\": \"https://example.com\",
+  \"dependencies\": {
+    \"runtime\": [
+      { \"name\": \"bundler\" },
+      { \"name\": \"bar\" }
+    ]
+  },
+  \"licenses\": [\"MIT\", \"Apache 2.0\"]
+}")
+
+(test-begin "gem")
+
+(test-assert "gem->guix-package"
+  ;; Replace network resources with sample data.
+  (mock ((guix import utils) url-fetch
+         (lambda (url file-name)
+           (match url
+             ("https://rubygems.org/api/v1/gems/foo.json"
+              (with-output-to-file file-name
+                (lambda ()
+                  (display test-json))))
+             (_ (error "Unexpected URL: " url)))))
+    (match (gem->guix-package "foo")
+      (('package
+         ('name "ruby-foo")
+         ('version "1.0.0")
+         ('source ('origin
+                    ('method 'url-fetch)
+                    ('uri ('rubygems-uri "foo" 'version))
+                    ('sha256
+                     ('base32
+                      "1a270mlajhrmpqbhxcqjqypnvgrq4pgixpv3w9gwp1wrrapnwrzk"))))
+         ('build-system 'ruby-build-system)
+         ('propagated-inputs
+          ('quasiquote
+           (("bundler" ('unquote 'bundler))
+            ("ruby-bar" ('unquote 'ruby-bar)))))
+         ('synopsis "A cool gem")
+         ('description "A cool gem")
+         ('home-page "https://example.com")
+         ('license ('list 'expat 'asl2.0)))
+       #t)
+      (x
+       (pk 'fail x #f)))))
+
+(test-end "gem")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))