summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ncurses.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 49a16bc058..52bc2867fe 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -90,14 +90,7 @@
           ;; Make sure programs like 'tic', 'reset', and 'clear' have a
           ;; correct RUNPATH.
           ,(string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")
-                          "/lib")
-
-          ;; C++ bindings fail to build on
-          ;; `i386-pc-solaris2.11' with GCC 3.4.3:
-          ;; <http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6395191>.
-          ,,@(if (string=? (%current-system) "i686-solaris")
-                 '("--without-cxx-binding")
-                 '()))
+                          "/lib"))
         #:tests? #f                               ; no "check" target
         #:phases (modify-phases %standard-phases
                    (add-after 'install 'post-install