summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm17
-rw-r--r--gnu/system/vm.scm6
2 files changed, 5 insertions, 18 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 000d1787f0..948af65bbd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -30,14 +30,14 @@
 (define-public guix
   (package
     (name "guix")
-    (version "0.3")
+    (version "0.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0xpfdmlfkkpmgrb8lpaqs5wxx31m4jslajs6b9waz5wp91zk7fix"))))
+               "1mmh28ds5p8mpzm2yfvgm6z92wgknqc3dlw6r6z16s13sk386igk"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list
@@ -104,16 +104,3 @@ A user-land free software distribution for GNU/Linux comes as part of Guix.
 Guix is based on the Nix package manager.")
     (license gpl3+)))
 
-(define-public guix-0.4
-  ;; XXX: Hack to allow the use of a 0.4ish tarball.  This assumes that you
-  ;; have run 'make dist' in your build tree.  Remove when 0.4 is out.
-  (let* ((builddir (dirname
-                    (canonicalize-path
-                     (dirname (search-path %load-path
-                                           "guix/config.scm")))))
-         (tarball  (string-append builddir "/guix-0.4.tar.gz")))
-    (package (inherit guix)
-      (version "0.4rc")
-      (source (if (file-exists? tarball)
-                  tarball
-                  (package-source guix))))))
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 32322b27e6..83b9f33456 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -390,7 +390,7 @@ such as /etc files."
               ("util-linux" ,util-linux)
 
               ,@(if initialize-store?
-                    `(("guix" ,guix-0.4))
+                    `(("guix" ,guix))
                     '())
 
               ,@inputs-to-copy)
@@ -462,7 +462,7 @@ Happy birthday, GNU!                                http://www.gnu.org/gnu30
           (mingetty-service store "tty5")
           (mingetty-service store "tty6")
           (syslog-service store)
-          (guix-service store #:guix guix-0.4)
+          (guix-service store)
           (nscd-service store)
 
           ;; QEMU networking settings.
@@ -540,7 +540,7 @@ Happy birthday, GNU!                                http://www.gnu.org/gnu30
                        ("procps" ,procps)
                        ("psmisc" ,psmisc)
                        ("zile" ,zile)
-                       ("guix" ,guix-0.4)))
+                       ("guix" ,guix)))
 
            ;; TODO: Replace with a real profile with a manifest.
            ;; TODO: Generate bashrc from packages' search-paths.