summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/crda-optional-gcrypt.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 995da1541c..fb661d4544 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -412,6 +412,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/cpio-fix-symlink-bad-length-test.patch	\
   gnu/packages/patches/cpio-gets-undeclared.patch		\
   gnu/packages/patches/cpufrequtils-fix-aclocal.patch		\
+  gnu/packages/patches/crda-optional-gcrypt.patch		\
   gnu/packages/patches/crossmap-allow-system-pysam.patch	\
   gnu/packages/patches/cssc-gets-undeclared.patch               \
   gnu/packages/patches/cssc-missing-include.patch               \
diff --git a/gnu/packages/patches/crda-optional-gcrypt.patch b/gnu/packages/patches/crda-optional-gcrypt.patch
new file mode 100644
index 0000000000..770ab1a97e
--- /dev/null
+++ b/gnu/packages/patches/crda-optional-gcrypt.patch
@@ -0,0 +1,20 @@
+This patch allows us to make the libgcrypt dependency optional (which it
+is, if you look at the code), which in turns allows us to build CRDA
+without the signature-checking capability on 'regulatory.bin'.
+
+--- crda/Makefile	2015-07-17 11:33:33.546712893 +0200
++++ crda/Makefile	2015-07-17 11:34:05.210994373 +0200
+@@ -45,12 +45,14 @@ LDLIBS += `pkg-config --libs openssl`
+ $(LIBREG): keys-ssl.c
+ 
+ else
++ifeq ($(USE_GCRYPT),1)
+ CFLAGS += -DUSE_GCRYPT
+ LDLIBS += -lgcrypt
+ 
+ $(LIBREG): keys-gcrypt.c
+ 
+ endif
++endif
+ MKDIR ?= mkdir -p
+ INSTALL ?= install