summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/graph.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 216b48195d..9dca2be98e 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -358,16 +358,15 @@ CPUFLAGS = ~{~a ~}~%"
                            (assoc-ref inputs "python*") python-version
                            (assoc-ref inputs "python-numpy") python-version
                            python-version
-                           (cons "-mpopcnt"
-                                 (list ,@(let ((system (or (%current-target-system)
-                                                           (%current-system))))
-                                           (cond
-                                            ((string-prefix? "x86_64" system)
-                                             '("-mavx" "-msse2"))
-                                            ((string-prefix? "i686" system)
-                                             '("-msse2"))
-                                            (else
-                                             '())))))))))
+                           (list ,@(let ((system (or (%current-target-system)
+                                                     (%current-system))))
+                                     (cond
+                                       ((string-prefix? "x86_64" system)
+                                        '("-mavx" "-msse2" "-mpopcnt"))
+                                       ((string-prefix? "i686" system)
+                                        '("-msse2" "-mpopcnt"))
+                                       (else
+                                         '()))))))))
              (substitute* "Makefile"
                (("../libfaiss.a") ""))
              (invoke "make" "cpu"))))))