summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/wine.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 42bec5cca5..b5d52170b1 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -66,7 +66,8 @@
   #:use-module (gnu packages vulkan)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
-  #:use-module (ice-9 match))
+  #:use-module (ice-9 match)
+  #:use-module (srfi srfi-1))
 
 (define-public wine
   (package
@@ -224,6 +225,23 @@ integrate Windows applications into your desktop.")
     (synopsis "Implementation of the Windows API (WoW64 version)")
     (supported-systems '("x86_64-linux" "aarch64-linux"))))
 
+;; This minimal build of Wine is needed to prevent a circular dependency with
+;; vkd3d.
+(define-public wine-minimal
+  (package
+    (inherit wine)
+    (name "wine-minimal")
+    (native-inputs (fold alist-delete (package-native-inputs wine)
+               '("gettext" "perl" "pkg-config")))
+    (inputs `())
+    (arguments
+     `(#:validate-runpath? #f
+       #:configure-flags
+       (list "--without-freetype"
+             "--without-x")
+       ,@(strip-keyword-arguments '(#:configure-flags)
+                                  (package-arguments wine))))))
+
 (define-public wine-staging-patchset-data
   (package
     (name "wine-staging-patchset-data")