summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crypto.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 028c140185..c4be604ff4 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -854,7 +854,9 @@ BLAKE.")
            ;; ./configure is not GNU autotools' and doesn't gracefully handle
            ;; unrecognized options, so we must call it manually.
            (lambda* (#:key configure-flags #:allow-other-keys)
-             (apply invoke "./configure" configure-flags)))
+             (apply invoke "./configure"
+                           (string-append "--extra-cflags=" (getenv "CFLAGS"))
+                           configure-flags)))
          (add-before 'check 'patch-/bin/sh
            (lambda _
              (substitute* "Makefile"