summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 63b144c45b..1252ba031b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3336,29 +3336,25 @@ language that is written in a Cyrillic alphabet.")
     (license license:lppl1.3c+)))
 
 (define-public texlive-latex-psnfss
-  (package
-    (name "texlive-latex-psnfss")
-    (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "psnfss"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "1920dcq8613yzprasbg80fh4fcjcidvvl54wkx438nimyxcri7qz"))))
-    (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/psnfss"))
-    (home-page "https://www.ctan.org/pkg/psnfss")
-    (synopsis "Font support for common PostScript fonts")
-    (description
-     "The PSNFSS collection includes a set of files that provide a complete
-working setup of the LaTeX font selection scheme (NFSS2) for use with common
-PostScript fonts.  It covers the so-called \"Base\" fonts (which are built
-into any Level 2 PostScript printing device and the Ghostscript interpreter)
-and a number of free fonts.  It provides font definition files, macros and
-font metrics.  The bundle as a whole is part of the LaTeX required set of
-packages.")
-    (license license:lppl1.2+)))
+  (let ((template (simple-texlive-package
+                   "texlive-latex-psnfss"
+                   (list "/doc/latex/psnfss/"
+                         "/tex/latex/psnfss/")
+                   (base32
+                    "12p23in2nz1n08hw3m6kf5mcbn9zbhjsvdx0nsb7zcvywbljb9i2")
+                   #:trivial? #t)))
+    (package
+      (inherit template)
+      (home-page "https://www.ctan.org/pkg/psnfss")
+      (synopsis "Font support for common PostScript fonts")
+      (description "The PSNFSS collection includes a set of files that
+provide a complete working setup of the LaTeX font selection
+scheme (NFSS2) for use with common PostScript fonts.  It covers the
+so-called \"Base\" fonts (which are built into any Level 2 PostScript
+printing device and the Ghostscript interpreter) and a number of free
+fonts.  It provides font definition files, macros and font metrics.
+The bundle as a whole is part of the LaTeX required set of packages.")
+      (license license:lppl1.2+))))
 
 ;; For user profiles
 (define-public texlive-base