summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/boost.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d6bdefcf83..3d620e2e26 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -148,6 +148,8 @@
            (lambda* (#:key make-flags #:allow-other-keys)
              (apply invoke "./b2"
                     (format #f "-j~a" (parallel-job-count))
+                    (string-append "cflags=" (getenv "CFLAGS"))
+                    (string-append "cxxflags=" (getenv "CXXFLAGS"))
                     make-flags)))
          (replace 'install
            (lambda* (#:key make-flags #:allow-other-keys)