summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux-initrd.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux-initrd.scm b/gnu/packages/linux-initrd.scm
index b62843aadd..ed30fa56b1 100644
--- a/gnu/packages/linux-initrd.scm
+++ b/gnu/packages/linux-initrd.scm
@@ -363,8 +363,7 @@ the Linux kernel.")
         (make-essential-device-nodes)
 
         ;; Prepare the real root file system under /root.
-        (unless (file-exists? "/root")
-          (mkdir "/root"))
+        (mkdir-p "/root")
         (if root
             ;; Assume ROOT has a usable /dev tree.
             (mount root "/root" "ext3")
@@ -374,6 +373,9 @@ the Linux kernel.")
 
         (mount-essential-file-systems #:root "/root")
 
+        (mkdir-p "/root/tmp")
+        (mount "none" "/root/tmp" "tmpfs")
+
         ;; XXX: We don't copy our fellow Guile modules to /root (see
         ;; 'qemu-initrd'), so if TO-LOAD tries to load a module (which can
         ;; happen if it throws, to display the exception!), then we're