summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/lua.scm25
-rw-r--r--gnu/packages/patches/lua-liblua-so.patch (renamed from gnu/packages/patches/lua52-liblua-so.patch)2
3 files changed, 22 insertions, 7 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1ac336196d..531e29b84a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -698,7 +698,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/lua-pkgconfig.patch                      \
   %D%/packages/patches/lua51-liblua-so.patch                    \
   %D%/packages/patches/lua51-pkgconfig.patch                    \
-  %D%/packages/patches/lua52-liblua-so.patch                    \
+  %D%/packages/patches/lua-liblua-so.patch                      \
   %D%/packages/patches/luajit-no_ldconfig.patch			\
   %D%/packages/patches/luajit-symlinks.patch			\
   %D%/packages/patches/luit-posix.patch				\
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 8fdba61e92..fe0ec208aa 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -40,15 +40,15 @@
 (define-public lua
   (package
     (name "lua")
-    (version "5.2.4")
+    (version "5.3.3")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://www.lua.org/ftp/lua-"
+             (uri (string-append "https://www.lua.org/ftp/lua-"
                                  version ".tar.gz"))
              (sha256
-              (base32 "0jwznq0l8qg9wh5grwg07b5cy3lzngvl5m2nl1ikp6vqssmf9qmr"))
+              (base32 "18mcfbbmjyp8f2l9yy7n6dzk066nq6man0kpwly4bppphilc04si"))
              (patches (search-patches "lua-pkgconfig.patch"
-                                      "lua52-liblua-so.patch"))))
+                                      "lua-liblua-so.patch"))))
     (build-system gnu-build-system)
     (inputs `(("readline" ,readline)))
     (arguments
@@ -69,7 +69,7 @@
                                (string-append "INSTALL_TOP=" out)
                                (string-append "INSTALL_MAN=" out
                                               "/share/man/man1")))))))))
-    (home-page "http://www.lua.org/")
+    (home-page "https://www.lua.org/")
     (synopsis "Embeddable scripting language")
     (description
      "Lua is a powerful, fast, lightweight, embeddable scripting language.  Lua
@@ -80,12 +80,25 @@ automatic memory management with incremental garbage collection, making it ideal
 for configuration, scripting, and rapid prototyping.")
     (license license:x11)))
 
+(define-public lua-5.2
+  (package (inherit lua)
+           (version "5.2.4")
+           (source
+            (origin
+              (method url-fetch)
+              (uri (string-append "https://www.lua.org/ftp/lua-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32 "0jwznq0l8qg9wh5grwg07b5cy3lzngvl5m2nl1ikp6vqssmf9qmr"))
+              (patches (search-patches "lua-pkgconfig.patch"
+                                       "lua-liblua-so.patch"))))))
+
 (define-public lua-5.1
   (package (inherit lua)
     (version "5.1.5")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://www.lua.org/ftp/lua-"
+             (uri (string-append "https://www.lua.org/ftp/lua-"
                                  version ".tar.gz"))
              (sha256
               (base32 "0cskd4w0g6rdm2q8q3i4n1h3j8kylhs3rq8mxwl9vwlmlxbgqh16"))
diff --git a/gnu/packages/patches/lua52-liblua-so.patch b/gnu/packages/patches/lua-liblua-so.patch
index 2e6b39ae79..0fad8dc90b 100644
--- a/gnu/packages/patches/lua52-liblua-so.patch
+++ b/gnu/packages/patches/lua-liblua-so.patch
@@ -1,3 +1,5 @@
+This applies to Lua 5.2 and 5.3.
+
 From 7a1b4e0829124976878ca2765a8e546667a92ceb Mon Sep 17 00:00:00 2001
 From: Leo Famulari <leo@famulari.name>
 Date: Fri, 30 Oct 2015 19:11:31 -0400