summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 4f1f7f577d..0c7aef9a5d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -169,8 +169,7 @@
                         (copy "armhf")
                         (copy "aarch64")
                         #t))
-                    (add-after
-                        'unpack 'disable-container-tests
+                    (add-after 'unpack 'disable-failing-tests
                       ;; XXX FIXME: These tests fail within the build container.
                       (lambda _
                         (substitute* "tests/syscalls.scm"
@@ -183,6 +182,12 @@
                           (substitute* "tests/guix-environment-container.sh"
                             (("guix environment --version")
                              "exit 77\n")))
+                        ;; XXX: On some file systems (notably Btrfs), the test
+                        ;; for freed disk space after GC may fail.  See
+                        ;; <https://bugs.gnu.org/29363>.
+                        (substitute* "tests/store.scm"
+                          (("(\\(> freed 0\\))" all)
+                           (string-append ";" all)))
                         #t))
                     (add-before 'check 'set-SHELL
                       (lambda _