summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--guix/swh.scm10
-rw-r--r--tests/swh.scm76
3 files changed, 83 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index b63c55d784..e36f2d9f21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -375,6 +375,7 @@ SCM_TESTS =					\
   tests/modules.scm				\
   tests/gnu-maintenance.scm			\
   tests/substitute.scm				\
+  tests/swh.scm					\
   tests/builders.scm				\
   tests/derivations.scm				\
   tests/glob.scm				\
diff --git a/guix/swh.scm b/guix/swh.scm
index 89cddb2bdd..d692f81806 100644
--- a/guix/swh.scm
+++ b/guix/swh.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,7 +31,9 @@
   #:use-module (ice-9 regex)
   #:use-module (ice-9 popen)
   #:use-module ((ice-9 ftw) #:select (scandir))
-  #:export (origin?
+  #:export (%swh-base-url
+
+            origin?
             origin-id
             origin-type
             origin-url
@@ -115,11 +117,11 @@
 
 (define %swh-base-url
   ;; Presumably we won't need to change it.
-  "https://archive.softwareheritage.org")
+  (make-parameter "https://archive.softwareheritage.org"))
 
 (define (swh-url path . rest)
   (define url
-    (string-append %swh-base-url path
+    (string-append (%swh-base-url) path
                    (string-join rest "/" 'prefix)))
 
   ;; Ensure there's a trailing slash or we get a redirect.
diff --git a/tests/swh.scm b/tests/swh.scm
new file mode 100644
index 0000000000..07f0fda37b
--- /dev/null
+++ b/tests/swh.scm
@@ -0,0 +1,76 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-swh)
+  #:use-module (guix swh)
+  #:use-module (guix tests http)
+  #:use-module (srfi srfi-64))
+
+;; Test the JSON mapping machinery used in (guix swh).
+
+(define %origin
+  "{ \"id\": 42,
+     \"visits_url\": \"/visits/42\",
+     \"type\": \"git\",
+     \"url\": \"http://example.org/guix.git\" }")
+
+(define %directory-entries
+  "[ { \"name\": \"one\",
+       \"type\": \"regular\",
+       \"length\": 123,
+       \"dir_id\": 1 }
+     { \"name\": \"two\",
+       \"type\": \"regular\",
+       \"length\": 456,
+       \"dir_id\": 2 } ]")
+
+(define-syntax-rule (with-json-result str exp ...)
+  (with-http-server 200 str
+    (parameterize ((%swh-base-url (%local-url)))
+      exp ...)))
+
+(test-begin "swh")
+
+(test-equal "lookup-origin"
+  (list 42 "git" "http://example.org/guix.git")
+  (with-json-result %origin
+    (let ((origin (lookup-origin "http://example.org/guix.git")))
+      (list (origin-id origin)
+            (origin-type origin)
+            (origin-url origin)))))
+
+(test-equal "lookup-origin, not found"
+  #f
+  (with-http-server 404 "Nope."
+    (parameterize ((%swh-base-url (%local-url)))
+      (lookup-origin "http://example.org/whatever"))))
+
+(test-equal "lookup-directory"
+  '(("one" 123) ("two" 456))
+  (with-json-result %directory-entries
+    (map (lambda (entry)
+           (list (directory-entry-name entry)
+                 (directory-entry-length entry)))
+         (lookup-directory "123"))))
+
+(test-end "swh")
+
+;; Local Variables:
+;; eval: (put 'with-json-result 'scheme-indent-function 1)
+;; End:
+