summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/video.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f19bdc7ef6..399327741f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1055,7 +1055,11 @@ H.264 (MPEG-4 AVC) video streams.")
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
            (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* (find-files "." ".*-viewer$")
+             (substitute* (find-files "lib" "\\.pm$")
+               (("\"youtube-dl\"")
+                (format #f "\"~a/bin/youtube-dl\""
+                        (assoc-ref inputs "youtube-dl"))))
+             (substitute* (find-files "bin" ".*-viewer$")
                (("'ffmpeg'")
                 (format #f "'~a/bin/ffmpeg'"
                         (assoc-ref inputs "ffmpeg")))