summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ac9245ac7b..e1742cf71b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4155,7 +4155,7 @@ addon modules.")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "WTForms" version ".tar.gz"))
+       (uri (pypi-uri "WTForms" version))
        (sha256
         (base32
          "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
@@ -4174,11 +4174,9 @@ addon modules.")
              (when tests?
                (add-installed-pythonpath inputs outputs)
                (invoke "python" "setup.py" "compile_catalog")
-               (invoke "coverage" "run" "tests/runtests.py" "--with-pep8")))))))
+               (invoke "python" "tests/runtests.py")))))))
     (native-inputs
-     `(("python-coverage" ,python-coverage)
-       ("python-dateutil" ,python-dateutil)
-       ("python-pep8" ,python-pep8)
+     `(("python-dateutil" ,python-dateutil)
        ("python-sqlalchemy" ,python-sqlalchemy)))
     (propagated-inputs
      `(("python-babel" ,python-babel)