summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index eb20d0fd54..f6f225c2f7 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1611,9 +1611,10 @@ python-fixtures package instead.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "python" "-m" "testtools.run"
-                     "fixtures.test_suite"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "testtools.run"
+                       "fixtures.test_suite")))))))
     (propagated-inputs
      ;; Fixtures uses pbr at runtime to check versions, etc.
      `(("python-pbr" ,python-pbr)