summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/abiword.scm8
-rw-r--r--gnu/packages/patches/abiword-black-drawing-with-gtk322.patch49
-rw-r--r--gnu/packages/patches/abiword-explictly-cast-bools.patch18
4 files changed, 5 insertions, 73 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index acbe99d34b..6fab0ddeca 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -17,7 +17,7 @@
 # Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 # Copyright © 2017, 2018, 2019 Gábor Boskovits <boskovits@gmail.com>
 # Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
-# Copyright © 2018, 2019 Oleg Pykhalov <go.wigust@gmail.com>
+# Copyright © 2018, 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 # Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
 # Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 # Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
@@ -694,7 +694,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/a2ps-CVE-2015-8107.patch	\
   %D%/packages/patches/abcl-fix-build-xml.patch	\
   %D%/packages/patches/abiword-explictly-cast-bools.patch	\
-  %D%/packages/patches/abiword-black-drawing-with-gtk322.patch	\
   %D%/packages/patches/adb-add-libraries.patch			\
   %D%/packages/patches/aegis-constness-error.patch         	\
   %D%/packages/patches/aegis-perl-tempdir1.patch           	\
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index db9f1bb72c..2b65a02242 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -47,7 +48,7 @@
 (define-public abiword
   (package
     (name "abiword")
-    (version "3.0.2")
+    (version "3.0.4")
     (source
       (origin
         (method url-fetch)
@@ -55,10 +56,9 @@
           (string-append "https://www.abisource.com/downloads/abiword/" version
                          "/source/abiword-" version ".tar.gz"))
         (sha256
-         (base32 "08imry821g81apdwym3gcs4nss0l9j5blqk31j5rv602zmcd9gxg"))
+         (base32 "1mx5l716n0z5788i19qmad30cck4v9ggr071cafw2nrf375rcc79"))
         (patches
-         (search-patches "abiword-explictly-cast-bools.patch"
-                         "abiword-black-drawing-with-gtk322.patch"))))
+         (search-patches "abiword-explictly-cast-bools.patch"))))
 
     (build-system glib-or-gtk-build-system)
     (arguments                   ;; NOTE: rsvg is disabled, since Abiword
diff --git a/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch b/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
deleted file mode 100644
index 88a5ca4c38..0000000000
--- a/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit 2ee38d1881aeea27bb49acc450631d813d1f28ba
-Author: Hubert Figuière <hub@figuiere.net>
-Date:   Wed Dec 7 09:44:01 2016 -0500
-
-    Bug 13815 - draw event should return TRUE
-    
-    This fix the black drawing regression witj Gtk3.22
-
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-index 780000e..10f8e00 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
- }
- 
- #if GTK_CHECK_VERSION(3,0,0)
--gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
-+gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
- #else
--gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
-+gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- #endif
- {
- 	XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
-@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- 		pView->draw(&rClip);
- #endif
- 	}
--	return FALSE;
-+	return TRUE;
- }
- 
- static bool bScrollWait = false;
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
-index 30ee5d8..a0ff57f 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.h
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
-@@ -152,9 +152,9 @@ protected:
- 			static gint key_release_event(GtkWidget* w, GdkEventKey* e);
- 			static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
- #if GTK_CHECK_VERSION(3,0,0)
--			static gint draw(GtkWidget * w, cairo_t * cr);
-+			static gboolean draw(GtkWidget * w, cairo_t * cr);
- #else
--			static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
-+			static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
- #endif
- 			static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
- 			static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);
diff --git a/gnu/packages/patches/abiword-explictly-cast-bools.patch b/gnu/packages/patches/abiword-explictly-cast-bools.patch
index 97ae6653c2..1d026a68b0 100644
--- a/gnu/packages/patches/abiword-explictly-cast-bools.patch
+++ b/gnu/packages/patches/abiword-explictly-cast-bools.patch
@@ -13,24 +13,6 @@ casted.
  }
  
  /*
-@@ -161,7 +161,7 @@ bool UT_JPEG_getDimensions(const UT_ByteBuf* pBB, UT_sint32& iImageWidth,
- 	/* set the data source */
- 	_JPEG_ByteBufSrc (&cinfo, pBB);
- 
--	jpeg_read_header(&cinfo, TRUE);
-+	jpeg_read_header(&cinfo, (boolean)TRUE);
- 	jpeg_start_decompress(&cinfo);
-     iImageWidth = cinfo.output_width;
-     iImageHeight = cinfo.output_height;
-@@ -189,7 +189,7 @@ bool UT_JPEG_getRGBData(const UT_ByteBuf* pBB, UT_Byte* pDest, UT_sint32 iDestRo
- 	/* set the data source */
- 	_JPEG_ByteBufSrc (&cinfo, pBB);
- 
--	jpeg_read_header(&cinfo, TRUE);
-+	jpeg_read_header(&cinfo, (boolean)TRUE);
- 	jpeg_start_decompress(&cinfo);
-     
- 	int row_stride = cinfo.output_width * cinfo.output_components;
 
 
 In the following file, we also need to reverse header include order: JPEG needs