summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/php.scm2
-rw-r--r--gnu/packages/textutils.scm14
2 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 90e6ab1c1c..1acab0de71 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -318,7 +318,7 @@
        ("libxpm" ,libxpm)
        ("libxslt" ,libxslt)
        ("libx11" ,libx11)
-       ("oniguruma" ,oniguruma)
+       ("oniguruma" ,oniguruma-5)
        ("openldap" ,openldap)
        ("openssl" ,openssl)
        ("pcre" ,pcre)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 9cf324ba15..355683df8a 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -355,6 +355,20 @@ characteristic of this library is that different character encoding for every
 regular expression object can be specified.")
     (license license:bsd-2)))
 
+;; PHP < 7.3.0 requires this old version.  Remove once no longer needed.
+(define-public oniguruma-5
+  (package
+    (inherit oniguruma)
+    (version "5.9.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/kkos/"
+                                  "oniguruma/releases/download/v" version
+                                  "/onig-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19s79vsclqn170mw0ajwv7j37qsbn4f1yjz3yavnhvva6c820r6m"))))))
+
 (define-public antiword
   (package
     (name "antiword")