summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/busybox.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index cc6257ba35..182b8ac618 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,8 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -133,7 +132,12 @@ any small or embedded system.")
              (let ((out (assoc-ref outputs "out")))
                (invoke "make"
                        (string-append "PREFIX=" out)
-                       "install")))))
+                       "install"))))
+         (add-after 'install 'remove-usr-directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (delete-file-recursively (string-append out "/usr"))
+               #t))))
        #:test-target "tests"))
     (native-inputs `(("bc" ,bc)))
     (synopsis "Many common UNIX utilities in a single executable")