summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/java.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b89dd794e6..23691fca26 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -871,6 +871,12 @@ requirement for all GNU Classpath releases after version 0.93.  This version
 supports sufficient parts of Java 7 to build Icedtea 2.x.")
     (license license:epl1.0)))
 
+(define ecj4-javac-wrapper
+  (package
+    (inherit ecj-javac-wrapper)
+    (native-inputs
+     (list guile-3.0 ecj4-bootstrap jamvm classpath-devel))))
+
 ;; The bootstrap JDK consisting of jamvm, classpath-devel,
 ;; ecj-javac-wrapper-final cannot build Icedtea 2.x directly, because it's
 ;; written in Java 7.  It can, however, build the unmaintained Icedtea 1.x,