summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b84faaff07..33a919458c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1080,6 +1081,26 @@ like.  It can be linked with various Emacs mail clients (Message and Mail
 mode, Rmail, Gnus, MH-E, and VM).  BBDB is fully customizable.")
     (license license:gpl3+)))
 
+(define-public emacs-aggressive-indent
+  (package
+    (name "emacs-aggressive-indent")
+    (version "1.8.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/"
+                                  "aggressive-indent-" version ".el"))
+              (sha256
+               (base32
+                "0jnzccl50x0wapprgwxinp99pwwa6j43q6msn4gv437j7swy8wnj"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/aggressive-indent.html")
+    (synopsis "Minor mode to aggressively keep your code always indented")
+    (description
+     "@code{aggressive-indent-mode} is a minor mode that keeps your code
+always indented.  It reindents after every change, making it more reliable
+than @code{electric-indent-mode}.")
+    (license license:gpl2+)))
+
 (define-public emacs-ag
   (package
     (name "emacs-ag")