summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 41e6b259e9..1115cef598 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -258,19 +258,18 @@ semiconductors.")
 (define-public gsl
   (package
     (name "gsl")
-    (version "2.3")
+    (version "2.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gsl/gsl-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1yxdzqjwmi2aid650fa9zyr8llw069x7lm489wx9nnfdi6vh09an"))
+                "16yfs5n444s03np1naj6yp1fsysd42kdscxzkg0k2yvfjixx0ijd"))
               (patches (search-patches "gsl-test-i686.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:parallel-tests? #f
-       ;; Currently there are numerous tests that fail on "exotic"
+     `(;; Currently there are numerous tests that fail on "exotic"
        ;; architectures such as aarch64 and ppc64le.
        ,@(if (string-prefix? "aarch64-linux"
                              (or (%current-target-system) (%current-system)))