summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/debug.scm5
-rw-r--r--gnu/packages/grub.scm8
2 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 9da8885fb3..82a8090d0c 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -161,7 +161,10 @@ tools that process C/C++ code.")
      ;; XXX: Disable tests because of GTester's rejection of duplicate test
      ;; names, which wasn't addressed in this version of QEMU.
      `(#:tests? #f
-       ,@(package-arguments qemu-minimal)))))
+       ,@(substitute-keyword-arguments (package-arguments qemu-minimal)
+           ((#:phases phases)
+            ;; We disable the tests so we skip the phase disabling the qga test.
+            `(modify-phases ,phases (delete 'disable-test-qga))))))))
 
 (define-public american-fuzzy-lop
   (let ((machine (match (or (%current-target-system)
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 3229b868c5..302fd0e1ae 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -22,6 +22,7 @@
 (define-module (gnu packages grub)
   #:use-module (guix download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:select (gpl3+))
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
@@ -58,7 +59,12 @@
     ;;   ERROR:tests/rtc-test.c:176:check_time: assertion failed (ABS(t - s) <= wiggle): (382597824 <= 2)
     ;; Simply disable the tests.
     (arguments `(#:tests? #f
-                 ,@(package-arguments qemu-minimal)))
+                 ,@(substitute-keyword-arguments (package-arguments qemu-minimal)
+                     ((#:phases phases)
+                      ;; We disable the tests so we also skip the phase disabling
+                      ;; the qga test, which fails due to changes in QEMU
+                      `(modify-phases ,phases
+                         (delete 'disable-test-qga))))))
 
     ;; The manual fails to build with Texinfo 5.x.
     (native-inputs (alist-delete "texinfo" (package-native-inputs qemu)))))