summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xmodmap-asprintf.patch14
-rw-r--r--gnu/packages/xorg.scm4
3 files changed, 18 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 3b131dd56b..fcaaced228 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -275,6 +275,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/valgrind-glibc.patch			\
   gnu/packages/patches/vpnc-script.patch			\
   gnu/packages/patches/w3m-fix-compile.patch			\
+  gnu/packages/patches/xmodmap-asprintf.patch			\
   gnu/packages/patches/xpdf-constchar.patch
 
 bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
diff --git a/gnu/packages/patches/xmodmap-asprintf.patch b/gnu/packages/patches/xmodmap-asprintf.patch
new file mode 100644
index 0000000000..6dfe8514e5
--- /dev/null
+++ b/gnu/packages/patches/xmodmap-asprintf.patch
@@ -0,0 +1,14 @@
+This patch allows the 'asprintf' declaration to be visible, by
+including <config.h>, which defines _GNU_SOURCE.
+
+
+--- xmodmap-1.0.7/xmodmap.c	2013-11-25 23:25:25.000000000 +0100
++++ xmodmap-1.0.7/xmodmap.c	2013-11-25 23:25:27.000000000 +0100
+@@ -26,6 +26,7 @@ from The Open Group.
+ 
+ */
+ 
++#include <config.h>
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3e5774e46e..c3441d76c4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -22,6 +22,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
@@ -3332,7 +3333,8 @@ tracking.")
                ".tar.bz2"))
         (sha256
           (base32
-            "1dg47lay4vhrl9mfq3cfc6741a0m2n8wd4ljagd21ix3qklys8pg"))))
+            "1dg47lay4vhrl9mfq3cfc6741a0m2n8wd4ljagd21ix3qklys8pg"))
+        (patches (list (search-patch "xmodmap-asprintf.patch")))))
     (build-system gnu-build-system)
     (inputs
       `(("xproto" ,xproto)