summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/telephony.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a645c58562..fe6c230693 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -15,6 +15,7 @@
 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
 ;;; Copyright © 2019 Ivan Vilata i Balaguer <ivan@selidor.net>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -462,6 +463,12 @@ address of one of the participants.")
              (substitute* "src/mumble/TextToSpeech_unix.cpp"
                (("libspeechd.h") "speech-dispatcher/libspeechd.h"))
              #t))
+         ;; disable statistic gathering by default. see <https://bugs.gnu.org/25201>
+         (add-before 'configure 'fix-statistic-gathering-default
+           (lambda _
+             (substitute* "src/mumble/Settings.cpp"
+               (("bUsage = true;") "bUsage = false;"))
+             #t))
          (add-before 'install 'disable-murmur-ice
            (lambda _
              (substitute* "scripts/murmur.ini.system"