summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--build-aux/hydra/guix.scm33
-rw-r--r--doc/guix.texi5
-rw-r--r--gnu/packages/ebook.scm1
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/services/base.scm15
-rw-r--r--guix/build-system/gnu.scm5
6 files changed, 32 insertions, 31 deletions
diff --git a/build-aux/hydra/guix.scm b/build-aux/hydra/guix.scm
index 3996a0b422..1035f81b4a 100644
--- a/build-aux/hydra/guix.scm
+++ b/build-aux/hydra/guix.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -68,25 +68,10 @@
     (home-page . ,(package-home-page package))
     (maintainers . ("bug-guix@gnu.org"))))
 
-(define (tarball-package checkout nix-checkout)
+(define (tarball-package checkout)
   "Return a package that does `make distcheck' from CHECKOUT, a directory
 containing a Git checkout of Guix."
-  (let ((dist (dist-package guix checkout)))
-    (package (inherit dist)
-      (location (source-properties->location (current-source-location)))
-      (arguments (substitute-keyword-arguments (package-arguments dist)
-                   ((#:phases p)
-                    `(alist-cons-before
-                      'autoreconf 'set-nix-submodule
-                      (lambda _
-                        ;; Tell Git to use the Nix checkout that Hydra gave us.
-                        (zero?
-                         (system* "git" "config" "submodule.nix-upstream.url"
-                                  ,nix-checkout)))
-                      ,p))))
-      (native-inputs `(("git" ,git)
-                       ("graphviz" ,graphviz)
-                       ,@(package-native-inputs dist))))))
+  (dist-package guix checkout))
 
 (define (hydra-jobs store arguments)
   "Return Hydra jobs."
@@ -104,13 +89,9 @@ containing a Git checkout of Guix."
   (define guix-checkout
     (assq-ref arguments 'guix))
 
-  (define nix-checkout
-    (assq-ref arguments 'nix))
-
-  (format (current-error-port) "using checkout ~s (Nix: ~s)~%"
-          guix-checkout nix-checkout)
-  (let ((guix (assq-ref guix-checkout 'file-name))
-        (nix  (assq-ref nix-checkout 'file-name)))
+  (let ((guix (assq-ref guix-checkout 'file-name)))
+    (format (current-error-port) "using checkout ~s (~s)~%"
+            guix-checkout guix)
     `((tarball . ,(cute package->alist store
-                        (tarball-package guix nix)
+                        (tarball-package guix)
                         (%current-system))))))
diff --git a/doc/guix.texi b/doc/guix.texi
index dd6af80965..c68e2915d1 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -4745,6 +4745,11 @@ passed to @command{guix-daemon}.
 Run @var{udev}, which populates the @file{/dev} directory dynamically.
 @end deffn
 
+@deffn {Monadic Procedure} console-keymap-service @var{file}
+Return a service to load console keymap from @var{file} using
+@command{loadkeys} command.
+@end deffn
+
 
 @node Networking Services
 @subsubsection Networking Services
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 101c5bad37..0d41121f3b 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -25,7 +25,6 @@
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages databases)
-  #:use-module (gnu packages ebook)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2232e8611e..4658df72fa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -198,7 +198,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
      #f)))
 
 (define-public linux-libre
-  (let* ((version "4.0")
+  (let* ((version "4.0.1")
          (build-phase
           '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
              ;; Apply the neat patch.
@@ -271,7 +271,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
              (uri (linux-libre-urls version))
              (sha256
               (base32
-               "12nkzn1n4si2zcp10b645qri83m2y7iwp29vs2rjmy612azdab8f"))
+               "1d5r26fh7dpdckvxfyn69r72h02yvri92rcmi2r658k56snsxs2k"))
              (patches
               (list (search-patch "linux-libre-libreboot-fix.patch")))))
     (build-system gnu-build-system)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index d0a2e8c848..697b9395c2 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +47,7 @@
             swap-service
             user-processes-service
             host-name-service
+            console-keymap-service
             console-font-service
             udev-service
             mingetty-service
@@ -313,6 +315,19 @@ stopped before 'kill' is called."
           (else
            (zero? (cdr (waitpid pid))))))))
 
+(define (console-keymap-service file)
+  "Return a service to load console keymap from @var{file}."
+  (with-monad %store-monad
+    (return
+     (service
+      (documentation
+       (string-append "Load console keymap (loadkeys)."))
+      (provision '(console-keymap))
+      (start #~(lambda _
+                 (zero? (system* (string-append #$kbd "/bin/loadkeys")
+                                 #$file))))
+      (respawn? #f)))))
+
 (define* (console-font-service tty #:optional (font "LatGrkCyr-8x16"))
   "Return a service that sets up Unicode support in @var{tty} and loads
 @var{font} for that tty (fonts are per virtual console in Linux.)"
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 3ccdef1328..2520224931 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -204,9 +204,10 @@ runs `make distcheck' and whose result is one or more source tarballs."
        ;; Add autotools & co. as inputs.
        (let ((ref (lambda (module var)
                     (module-ref (resolve-interface module) var))))
-         `(("autoconf" ,(ref '(gnu packages autotools) 'autoconf))
+         `(,@(package-native-inputs p)
+           ("autoconf" ,(ref '(gnu packages autotools) 'autoconf))
            ("automake" ,(ref '(gnu packages autotools) 'automake))
-           ("libtool"  ,(ref '(gnu packages autotools) 'libtool) "bin")
+           ("libtool"  ,(ref '(gnu packages autotools) 'libtool))
            ("gettext"  ,(ref '(gnu packages gettext) 'gnu-gettext))
            ("texinfo"  ,(ref '(gnu packages texinfo) 'texinfo))))))))