summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
-rw-r--r--doc.am4
2 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7a7262f967..934ced5d72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,10 @@ AC_CACHE_SAVE
 
 m4_include([config-daemon.ac])
 
+dnl `dot' (from the Graphviz package) is only needed for maintainers.
+dnl See `HACKING' for more info.
+AM_MISSING_PROG([DOT], [dot])
+
 AC_CONFIG_FILES([Makefile
                  po/Makefile.in
 		 guix/config.scm])
diff --git a/doc.am b/doc.am
index afd492c605..2bc3416edd 100644
--- a/doc.am
+++ b/doc.am
@@ -33,11 +33,11 @@ DOT_OPTIONS =						\
   -Nfontsize=9 -Nheight=.1 -Nwidth=.1
 
 .dot.png:
-	dot -Tpng $(DOT_OPTIONS) < "$<" > "$@.tmp"
+	$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$@.tmp"
 	mv "$@.tmp" "$@"
 
 .dot.eps:
-	dot -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
+	$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
 	mv "$@.tmp" "$@"
 
 # We cannot add new dependencies to `doc/guix.pdf' & co. (info "(automake)