summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/hurd.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 45e1b21a77..e5ad8e4f73 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -409,6 +409,16 @@ fsysopts / --writable\n"))
                            (patch-shebang file path))
                          (find-files (string-append out "/libexec")))
                #t)))
+         (add-after 'install 'install-goodies
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Install additional goodies.
+             ;; TODO: Build & install *.msgids for rpctrace.
+             (let ((out (assoc-ref outputs "out")))
+               ;; Install the fancy UTF-8 motd.
+               (mkdir-p (string-append out "/etc"))
+               (copy-file "console/motd.UTF8"
+                          (string-append out "/etc/motd"))
+               #t)))
          (add-after 'install 'install-rc-file
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))