summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi3
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index afbf4eb20a..d9d7ffd6c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -818,6 +818,7 @@ release: dist-with-updated-version
 	for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do					\
 	  image=`$(top_builddir)/pre-inst-env						\
 	    guix system vm-image $(GUIX_SYSTEM_VM_IMAGE_FLAGS)				\
+	    --save-provenance								\
 	    --system=$$system --fallback						\
 	    gnu/system/examples/vm-image.tmpl` ;					\
 	  if [ ! -f "$$image" ] ; then							\
diff --git a/doc/guix.texi b/doc/guix.texi
index f6522a9942..0fb81e441f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -27252,7 +27252,8 @@ This image boots the Xfce graphical environment and it contains some
 commonly-used tools.  You can install more software in the image by running
 @command{guix package} in a terminal (@pxref{Invoking guix package}).  You can
 also reconfigure the system based on its initial configuration file available
-as @file{/etc/config.scm} (@pxref{Using the Configuration System}).
+as @file{/run/current-system/configuration.scm} (@pxref{Using the
+Configuration System}).
 
 Instead of using this pre-built image, one can also build their own virtual
 machine image using @command{guix system vm-image} (@pxref{Invoking guix