summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-ark-remove-mibstore.patch23
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 28 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 16993df378..d4e027f7e2 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -458,6 +458,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/vpnc-script.patch			\
   gnu/packages/patches/w3m-fix-compile.patch			\
   gnu/packages/patches/wmctrl-64-fix.patch			\
+  gnu/packages/patches/xf86-video-ark-remove-mibstore.patch	\
   gnu/packages/patches/xf86-video-openchrome-includes.patch	\
   gnu/packages/patches/xfce4-panel-plugins.patch		\
   gnu/packages/patches/xmodmap-asprintf.patch
diff --git a/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch b/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch
new file mode 100644
index 0000000000..4a5b629b43
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch
@@ -0,0 +1,23 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server.  Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-ark-0.7.5/src/ark_driver.c.~1~	2012-07-17 00:51:36.000000000 -0400
++++ xf86-video-ark-0.7.5/src/ark_driver.c	2014-12-19 00:23:13.028931734 -0500
+@@ -39,7 +39,6 @@
+ #include "compiler.h"
+ #include "mipointer.h"
+ #include "micmap.h"
+-#include "mibstore.h"
+ #include "fb.h"
+ #include "ark.h"
+ 
+@@ -538,7 +537,6 @@
+ 
+ 	fbPictureInit (pScreen, 0, 0);
+ 
+-	miInitializeBackingStore(pScreen);
+ 	xf86SetBackingStore(pScreen);
+ 
+ 	if (!pARK->NoAccel) {
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 78fdc21e02..94a9dbe1b5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2360,17 +2360,18 @@ devices, thus making direct access unnecessary.")
 (define-public xf86-video-ark
   (package
     (name "xf86-video-ark")
-    (version "0.7.4")
+    (version "0.7.5")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/xf86-video-ark-"
+               "mirror://xorg/individual/driver/xf86-video-ark-"
                version
                ".tar.bz2"))
         (sha256
           (base32
-            "194zc35ivfh3vcxcilf9nbi88c2di8kbh84x535cljlpiajdnk5x"))))
+           "07p5vdsj2ckxb6wh02s61akcv4qfg6s1d5ld3jn3lfaayd3f1466"))
+        (patches (list (search-patch "xf86-video-ark-remove-mibstore.patch")))))
     (build-system gnu-build-system)
     (inputs `(("xorg-server" ,xorg-server)))
     (native-inputs `(("pkg-config" ,pkg-config)))