summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/hurd.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index ca7d7e97a3..6478eb4434 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -370,7 +370,13 @@ boot, since this cannot be done from GNU/Linux."
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
-       ("mig" ,mig)
+       ("mig" ,(if (%current-target-system)
+                   ;; XXX: When targeting i586-pc-gnu, we need a 32-bit MiG,
+                   ;; hence this hack.
+                   (package
+                     (inherit mig)
+                     (arguments `(#:system "i686-linux")))
+                   mig))
        ("perl" ,perl)
        ("texinfo" ,texinfo-4)))
     (supported-systems %hurd-systems)