summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6a865e6f36..eb2c65f205 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13774,3 +13774,28 @@ editors.")
     (description "@code{python2-backports-functools-lru-cache} is a backport
 of @code{functools.lru_cache} from python 3.3.")
     (license license:expat)))
+
+(define-public python-configparser
+  (package
+    (name "python-configparser")
+    (version "3.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://bitbucket.org/ambv/configparser/get/"
+             version ".tar.bz2"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0waq40as14abwzbb321hfz4vr1fi363nscy32ga14qvfygrg96wa"))))
+    (build-system python-build-system)
+    (home-page "http://docs.python.org/py3k/library/configparser.html")
+    (synopsis "Backport of configparser from python 3.5")
+    (description "@code{python-configparser} is a backport of
+@code{configparser} from Python 3.5 so that it can be used directly
+in other versions.")
+    (license license:expat)))
+
+(define-public python2-configparser
+  (package-with-python2 python-configparser))