summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/boost.scm10
-rw-r--r--gnu/packages/compression.scm2
-rw-r--r--gnu/packages/mpd.scm2
-rw-r--r--gnu/packages/storage.scm2
5 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 678bbcf55f..b732f7c608 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2274,7 +2274,7 @@ external_libraries/yaml-cpp/include)"))
        ("eudev" ,eudev)                 ;for user interactions with devices
        ("avahi" ,avahi)                 ;zeroconf service discovery support
        ("icu4c" ,icu4c)
-       ("boost" ,boost-cxx14)
+       ("boost" ,boost)
        ("boost-sync" ,boost-sync)
        ("yaml-cpp" ,yaml-cpp)))
     (home-page "https://github.com/supercollider/supercollider")
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index f1ff1712e6..f5c2c58300 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -123,16 +123,6 @@ across a broad spectrum of applications.")
     (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
                                 "Some components have other similar licences."))))
 
-;; Some programs need Boost to be built with C++14 support.
-(define-public boost-cxx14
-  (package (inherit boost)
-    (arguments
-      (substitute-keyword-arguments (package-arguments boost)
-        ((#:make-flags flags)
-         `(append ,flags
-                  '("cxxflags=-std=c++14")))))
-    (properties '((hidden? . #t)))))
-
 (define-public boost-for-mysql
   ;; Older version for MySQL 5.7.23.
   (package
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index c33d7ef093..c87ccda304 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -2263,7 +2263,7 @@ single-member files which can't be decompressed in parallel.")
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f)) ;; No tests available.
-   (inputs `(("boost" ,boost-cxx14)
+   (inputs `(("boost" ,boost)
              ("libiconv" ,libiconv)
              ("xz" ,xz)))
    (native-inputs `(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 0a81a3b8b8..fe8610ab94 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -244,7 +244,7 @@ terminal using ncurses.")
                 "0m0mjb049sl62vx13h9waavysa30mk0rphacksnvf94n13la62v5"))))
     (build-system gnu-build-system)
     (inputs `(("libmpdclient" ,libmpdclient)
-              ("boost"  ,boost-cxx14)
+              ("boost"  ,boost)
               ("readline" ,readline)
               ("ncurses" ,ncurses)
               ("taglib" ,taglib)
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 4eae37815e..5051ccd986 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -321,7 +321,7 @@
        ("python2-testtools" ,python2-testtools)
        ("python2-tox" ,python2-tox)))
     (inputs
-     `(("boost" ,boost-cxx14)
+     `(("boost" ,boost)
        ("curl" ,curl)
        ("cryptsetup" ,cryptsetup)
        ("expat" ,expat)