summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/ghostscript.scm28
-rw-r--r--gnu/packages/gv.scm62
3 files changed, 63 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index 61d8bddf0e..e2d8100e11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -110,6 +110,7 @@ MODULES =					\
   gnu/packages/gsasl.scm			\
   gnu/packages/gtk.scm				\
   gnu/packages/guile.scm			\
+  gnu/packages/gv.scm				\
   gnu/packages/help2man.scm			\
   gnu/packages/icu4c.scm			\
   gnu/packages/idutils.scm			\
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 6781ffecdf..04aac9d94e 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -27,7 +27,6 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages tcl)
-  #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -135,8 +134,6 @@ printing, and psresize, for adjusting page sizes.")
              ("libpng" ,libpng)
              ("libpaper" ,libpaper)
              ("libtiff" ,libtiff)
-             ("libxext" ,libxext)
-             ("libxt" ,libxt)
              ("perl" ,perl)
              ("pkg-config" ,pkg-config) ; needed to find libtiff
              ("python" ,python)
@@ -217,28 +214,3 @@ Ghostscript. It currently includes the 35 standard PostScript fonts.")
    (license license:gpl2)
    (home-page "http://sourceforge.net/projects/gs-fonts/")))
 
-(define-public gv
-  (package
-   (name "gv")
-   (version "3.7.4")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "mirror://gnu/gv/gv-"
-                                version ".tar.gz"))
-            (sha256 (base32
-                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
-   (build-system gnu-build-system)
-   (propagated-inputs `(("ghostscript" ,ghostscript)))
-   (inputs `(("libx11" ,libx11)
-             ("libxaw3d" ,libxaw3d)
-             ("libxinerama" ,libxinerama)
-             ("libxpm" ,libxpm)
-             ("pkg-config" ,pkg-config)
-             ("zlib" ,zlib)))
-   (synopsis "postscript and pdf viewer for x")
-   (description
-    "GNU gv allows to view and navigate through PostScript and PDF documents
-on an X display by providing a graphical user interface for the Ghostscript
-interpreter.")
-   (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/gv/")))
diff --git a/gnu/packages/gv.scm b/gnu/packages/gv.scm
new file mode 100644
index 0000000000..870b3581fb
--- /dev/null
+++ b/gnu/packages/gv.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gv)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xorg)
+  #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public ghostscript/x
+  (package (inherit ghostscript)
+    (name (string-append (package-name ghostscript) "-with-x"))
+    (inputs `(("libxext" ,libxext)
+              ("libxt" ,libxt)
+              ,@(package-inputs ghostscript)))))
+
+(define-public gv
+  (package
+   (name "gv")
+   (version "3.7.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnu/gv/gv-"
+                                version ".tar.gz"))
+            (sha256 (base32
+                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
+   (build-system gnu-build-system)
+   (propagated-inputs `(("ghostscript" ,ghostscript/x)))
+   (inputs `(("libx11" ,libx11)
+             ("libxaw3d" ,libxaw3d)
+             ("libxinerama" ,libxinerama)
+             ("libxpm" ,libxpm)
+             ("pkg-config" ,pkg-config)
+             ("zlib" ,zlib)))
+   (synopsis "postscript and pdf viewer for x")
+   (description
+    "GNU gv allows to view and navigate through PostScript and PDF documents
+on an X display by providing a graphical user interface for the Ghostscript
+interpreter.")
+   (license license:gpl3+)
+   (home-page "http://www.gnu.org/software/gv/")))