summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ccache.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 01db7ae57d..9b8c147e69 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -43,14 +43,13 @@
                      ("which" ,(@ (gnu packages base) which))))
     (inputs `(("zlib" ,zlib)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'check 'setup-tests
-                 (lambda _
-                   (substitute* '("test/test_hashutil.c" "test.sh")
-                     (("#!/bin/sh") (string-append "#!" (which "sh")))
-                     (("which") (which "which")))
-                   #t)
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                 (add-before 'check 'setup-tests
+                   (lambda _
+                     (substitute* '("test/test_hashutil.c" "test.sh")
+                       (("#!/bin/sh") (string-append "#!" (which "sh")))
+                       (("which") (which "which")))
+                     #t)))))
     (home-page "https://ccache.samba.org/")
     (synopsis "Compiler cache")
     (description