summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bittorrent.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0f63c3d0f2..03c7fe4515 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -94,10 +94,13 @@
                             (string-append gui
                                            "/bin/transmission-gtk"))
 
-               ;; Move the '.desktop' file as well.
+               ;; Move the '.desktop' and icon files as well.
                (mkdir (string-append gui "/share"))
-               (rename-file (string-append out "/share/applications")
-                            (string-append gui "/share/applications")))
+               (for-each
+                (lambda (dir)
+                  (rename-file (string-append out "/share/" dir)
+                               (string-append gui "/share/" dir)))
+                '("applications" "icons" "pixmaps")))
              #t)))))
     (inputs
      `(("inotify-tools" ,inotify-tools)