summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vpn.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 17dd163c53..c4e0287bf8 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -722,27 +722,26 @@ and probably others.")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-openconnect
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "openconnect_sso/app.py"
                (("\"openconnect\"")
-                (string-append "\"" (which "openconnect") "\"")))
-             #t))
+                (string-append "\""
+                               (search-input-file inputs "/sbin/openconnect")
+                               "\"")))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-v"))
-             #t))
+               (invoke "pytest" "-v"))))
          (add-after 'install 'wrap-qt-process-path
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin/openconnect-sso"))
-                    (qt-process-path (string-append
-                                       (assoc-ref inputs "qtwebengine-5")
-                                       "/lib/qt5/libexec/QtWebEngineProcess")))
+                    (qt-process-path
+                     (search-input-file inputs
+                                        "/lib/qt5/libexec/QtWebEngineProcess")))
                (wrap-program bin
                  #:sh (search-input-file inputs "bin/bash")
-                 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
-               #t))))))
+                 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
     (inputs
      (list openconnect
            python-attrs