summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch20
3 files changed, 24 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2835329141..3335d368df 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1584,6 +1584,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/p7zip-remove-unused-code.patch		\
   %D%/packages/patches/pam-krb5-CVE-2020-10595.patch		\
   %D%/packages/patches/pango-skip-libthai-test.patch		\
+  %D%/packages/patches/passwordsafe-meson-remove-extra-argument.patch \
   %D%/packages/patches/pciutils-hurd-configure.patch		\
   %D%/packages/patches/pciutils-hurd-fix.patch			\
   %D%/packages/patches/pitivi-fix-build-with-meson-0.60.patch	\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index beae828f5a..7bce80b2d7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10765,16 +10765,16 @@ apply fancy special effects and lets you share the fun with others.")
 (define-public passwordsafe
   (package
     (name "passwordsafe")
-    (version "5.0")
+    (version "5.1")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://gitlab.gnome.org/World/PasswordSafe")
+             (url "https://gitlab.gnome.org/World/secrets")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1xh64bbg10gnfzlck5jvqy2zk6hbk9cyqgv85xc9kbdvs8n4lhgh"))))
+        (base32 "0kd43j6i017wdsqj6d5gnxhfv4ijnh3xahlw7md2gh51i8p682j6"))))
     (build-system meson-build-system)
     (arguments
      (list #:glib-or-gtk? #t
diff --git a/gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch b/gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch
new file mode 100644
index 0000000000..3cb61a364a
--- /dev/null
+++ b/gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch
@@ -0,0 +1,20 @@
+diff --git a/data/meson.build b/data/meson.build
+index 46f6373..26a2c18 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -35,7 +35,6 @@ if get_option('profile') == 'development'
+ endif
+ desktop_conf.set('ICON', application_id)
+ desktop = i18n.merge_file(
+-  'desktop',
+   input: configure_file(
+     input: files('org.gnome.PasswordSafe.desktop.in.in'),
+     output: 'org.gnome.PasswordSafe.desktop.in',
+@@ -65,7 +64,6 @@ if get_option('profile') == 'development'
+ endif
+ appdata_conf.set('APPID', application_id)
+ appdata = i18n.merge_file(
+-  'appdata',
+   input: configure_file(
+     input: files('org.gnome.PasswordSafe.appdata.xml.in.in'),
+     output: 'org.gnome.PasswordSafe.appdata.xml.in',