summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compression.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1ca88fe78c..1321791841 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1588,7 +1588,12 @@ recreates the stored directory structure by default.")
                     (lambda _
                       (for-each make-file-writable
                                 (find-files "test" #:directories? #t))
-                      #t)))))
+                      #t)))
+
+       ;; XXX: The default test target attempts to download external resources and
+       ;; fails without error: <https://github.com/gdraheim/zziplib/issues/53>.
+       ;; To prevent confusing log messages, just run a simple zip test that works.
+       #:test-target "check-readme"))
     (inputs
      `(("zlib" ,zlib)))
     (native-inputs `(("perl" ,perl)     ; for the documentation