summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 3fb42f8026..f187c02ba4 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -795,14 +795,12 @@ communicate with each other.  Here's a few things KDE Connect can do:
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                ;; This test fails, I don't know why.
-               (invoke "ctest" "-E" "parsertest"))
-             #t)))))
-    (native-inputs
-     `(("bison" ,bison)
-       ("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("qttools-5" ,qttools-5)))
+               (invoke "ctest" "-E" "parsertest")))))))
+    (native-inputs (list bison
+                         extra-cmake-modules
+                         pkg-config
+                         python-wrapper
+                         qttools-5))
     (inputs
      (list breeze ;for dark themes
            breeze-icons ;for icons