summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 9f3ef031c3..5e6d188ec4 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -164,7 +164,8 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
 
        ;; The test suite takes many times longer than building and
        ;; can easily fail on smaller machines when they run out of memory.
-       #:tests? ,(not (target-aarch64?))
+       #:tests? ,(not (or (%current-target-system)
+                          (target-aarch64?)))
 
        ;; Do not strip binaries to keep support for full backtraces.
        ;; See https://github.com/JuliaLang/julia/issues/17831