summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 061c9a5a1e..d71b2991ad 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1677,6 +1677,12 @@ module that provides platform integration: native dialogs, menus and menu bars,
 and tray icons.  It falls back to Qt Widgets when a native implementation is
 not available.")))
 
+(define-public qtquickcontrols2
+  ;; qtquickcontrols2 still exist, but was merged into qtdeclarative.
+  ;; Unfortunately that hasn't been well communicated at all (see:
+  ;; https://bugreports.qt.io/browse/QTBUG-79454).
+  (deprecated-package "qtquickcontrols2" qtdeclarative))
+
 (define-public qtgraphicaleffects
   (package (inherit qtsvg-5)
     (name "qtgraphicaleffects")