summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8aee3352aa..70bc458d67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22764,7 +22764,8 @@ decisions with any given backend.")
                 (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
                                m)))))
          (replace 'check
-           (lambda _ (invoke "pytest" "-vv"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests? (invoke "pytest" "-vv")))))))
     (propagated-inputs
      `(("python-cloudpickle" ,python-cloudpickle)
        ("python-fsspec" ,python-fsspec)