summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 391cfac77e..5fe01e27c6 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -124,6 +124,8 @@ X11 (yet).")
                       "-prefix" out
                       "-opensource"
                       "-confirm-license"
+                      ;; explicitly link with dbus instead of dlopening it
+                      "-dbus-linked"
                       ;; drop special machine instructions not supported
                       ;; on all instances of the target
                       ,@(if (string-prefix? "x86_64"
@@ -191,6 +193,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                       "-prefix" out
                       "-opensource"
                       "-confirm-license"
+                      ;; explicitly link with dbus instead of dlopening it
+                      "-dbus-linked"
                       ;; drop special machine instructions not supported
                       ;; on all instances of the target
                       ,@(if (string-prefix? "x86_64"