summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f05047bb9c..a5b4b7578d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1765,7 +1765,10 @@ library.")
          (add-after 'install 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
-             (invoke "py.test" "src/geventhttpclient/tests" "-v")
+             (invoke "py.test"  "src/geventhttpclient/tests" "-v"
+                     ;; Append the test modules to sys.path to avoid
+                     ;; namespace conflict which breaks SSL tests.
+                     "--import-mode=append")
              #t)))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))