summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ad2d9cff97..758973c33d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3962,3 +3962,26 @@ abbreviation and automatically expand it into function templates.")
    (description "@code{emacs-memoize} is an Emacs library for
 memoizing functions.")
    (license license:unlicense)))
+
+(define-public emacs-idle-highlight
+  (package
+    (name "emacs-idle-highlight")
+    (version "1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/nonsequitur/idle-highlight-mode/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0kdv10hrgqpskjh0zvpnzwlkn5bccnqxas62gkws6njln57bf8nl"))))
+    (build-system emacs-build-system)
+    (home-page "https://www.emacswiki.org/emacs/IdleHighlight")
+    (synopsis "Highlights all occurences of the word the point is on")
+    (description
+     "This Emacs package provides @code{idle-highlight-mode} that sets
+ an idle timer to highlight all occurences in the buffer of the word under
+ the point.")
+    (license license:gpl3+)))