summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5496ea9c9e..e8d28d6060 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -168,10 +168,10 @@ bind processes, and much more.")
      `(("hwloc" ,hwloc "lib")
        ("gfortran" ,gfortran)
        ("libfabric" ,libfabric)
-       ,@(match (%current-system)
-                ((member (package-supported-systems psm))
-                 `(("psm" ,psm)))
-                (_ `()))
+       ,@(if (and (not (%current-target-system))
+                  (member (%current-system) (package-supported-systems psm)))
+             `(("psm" ,psm))
+             '())
        ("rdma-core" ,rdma-core)
        ("valgrind" ,valgrind)))
     (native-inputs