summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a32ac206ac..9a08ad4f41 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -247,6 +247,14 @@ DNS domain name queries.")
         (base32
          "0a92lk8790dpp9j64vb6p4sazax0x3nby01lnfll7mxs1hx6n27q"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-paths
+           (lambda _
+             (substitute* "sshoot/tests/test_manager.py"
+               (("/bin/sh") (which "sh")))
+             #t)))))
     (inputs
      `(("python-argcomplete" ,python-argcomplete)
        ("python-prettytable" ,python-prettytable)