summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/chromium.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index d43e53591e..8fdaeeda9f 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -330,6 +330,15 @@ from forcing GEXP-PROMISE."
                    (force-output)
                    (invoke "tar" "xf" #+chromium-source)
 
+                   (format #t "Removing non-free file...~%")
+                   (force-output)
+                   ;; This file has a CC-BY-NC clause according to LICENSES from
+                   ;; the same directory, making it non-free.
+                   (delete-file
+                    (string-append
+                     chromium-dir
+                     "/third_party/blink/perf_tests/svg/resources/HarveyRayner.svg"))
+
                    ;; Ungoogled-Chromium contains a forked subset of the Debian
                    ;; patches.  Disable those, as we apply newer versions later.
                    (substitute* "patches/series"